® Tracker Reference Guide

The following guide shows how to do the most common tasks in Tracker. The different
topics are ordered in the sequence you will typically use them in, although, if you want

to jump to a specific topic, you can use the table of contents to navigate there directly.
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Download and Install Tracker

1. Go to https://physlets.org/tracker/ and download the installer for your computer’s
operating system (Windows, MacOS, or Linux).

Tracker Home | Help | Share | OSP Home | Email Doug

®Tracker

Video Analysis and Modeling Tool

Over 1 million users in 26 languages. Completely free and open source.
Tracker 5.1.5 installers: Windows OS X Linux 32-bit Linux 64-bit

Already have Tracker? Upgrade now to version 5.1.5: Windows OSX Linux32 Linux 64

08X users: control-click the installer and choose Open from the popup menu rather than double-clicking.

Installer Help Change Log Discussion Forum

2. Run the installer. This will walk you through the installation steps to install
Tracker on your computer.

3. Open Tracker.

@ Tracker — m] X
File Edit Video Track Coordinate System View Help

EH| S B8 - || Kceate =0 B | Qoes |~ 0y | 4 A A F 4 A #£- @ 3 C
v memory in use: 16MB of 247TMB
Main view of video and fracks will appear here L a

oo

Choose File|Open or Tracks|New fo start.
Plot view of track data will appear here

Table view of track data will appear here

|upen orimport a video to analyze

;Egoouwuu%Elu » O 201 E

&

Untitied |
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https://physlets.org/tracker/

Warning to iPhone/iPad Users

If you use an iPhone or iPad to record videos for the experiment, the camera format
must be set to “Most Compatible”. Otherwise, Tracker will not recognize the files.

1. Open the Settings App

2. Go to Camera > Formats and select Most Compatible.

!l ATRT = 14:41 765%@) . ATRT T 14:41 v 65% @ ol ATRT T 14:41 4 65% @ )
Settings { Settings Camera { Camera Formats
&_: Maps
CAMERA CAPTURE
Preserve Settings
Compass . -
High Efficiency
. Measure Grid
| Most Compatible v
) Scan QR Codes )
@ Safari A/ To reduce file size, capture photos and videos in the high
. efficiency HEIF/HEVC format. Most Compatible will always
N Record Video 108C 30 fps use JPEG/H.264.
N News
@ Health Record Slo-mo 720p at 240 fps
Formats |
Home
s Shortcuts
HDR (HIGH DYNAMIC RANGE)
Keep Normal Photo
f Music HDR blends the best parts of three separate exposures into a
single photo. Save the normally exposed photo in addition to
& Photos
I Bl Camera
Books
& Game Center

Note: These instructions are accurate as of iOS/iPadOS 13. With future updates to the

OS, the location of this setting may change. If you cannot find this setting, simply search

the settings app for “Camera” or “Formats”.
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Open Video File

1. Click the Open File icon.

SlE & Bl B - | ¥ create

g 108%

2. Select the video file you want to open and click Open.

*

| £ Open

Look In;

] Desktop -

*

o-0-
o-0-

=

3 OneDrive
3 Admin
3 This PC
] Libraries

3 Network
[ IMG_2235.M0V

File Name: |Ir-.-1G_2235.r-.-1G‘-.-"

Files of Type: |Video and Tracker Files

Open Cancel
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Save the Tracker File

1. Click the Save File icon.

Sld| & B - || Xcreate == £ | (Q108% | . 0lp

2. Choose a file location, name the file, and click Save.

@ save Tab s

Save In: |] Desktop - I:' E

File Name: IMG_2235.1rk

Files of Type: |Tracker File (.irk) -

Save Cancel
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Rotate the Video
If your video was filmed vertically or upside-down, use the video filters to rotate it.
1. Click Video on the top menu bar.

2. Go to Filters > New > Rotate

() Tracker — O x
File Edit Track Coordinate System View Help

o Replace... & a o =

= H CIopse e o B | Qsew | 0 |\ o A A4 A0 A #- 8 8 C
v Goto... Ctrl-G memory in use: 41MB of 247TMB

Paste Image 3

L)
¥l k= -

Plot view of track data will appear here

¥ visible
¥ Play All Steps
¥ Smooth Play (may be slow)

Baseline
Frame Durations... Brightness
Properties...

Table view of track data will appear here

setar review video clip settings

fgfnonmn%Eln LRV UL N

[ RRRRRO

IMG_2235k |

3. Choose the appropriate rotation option and click Close.

Rotate Filter -
Rotation
' None
O +00" e~
W _O)°
180"
[ | Reverse
Disable Close
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Calibration

In order for Tracker to accurately determine position, velocity, acceleration. from your
video, you need to label the size of something that is close to the object you will track. In
the experiments, you will use a ruler, measuring tape, or meter stick if you have one.

1. Go to Calibration Tools > New > Calibration Stick.

= &2 B | B | - | ¥create = ¥ | Q3% . 0l
v New » Calibration Stick

Calibration Ta 7
L s

- | Calibration Points

| Offset Origin

2. Hold down Shift on the keyboard and Click on the end points of your ruler,
measuring tape, meter stick, etc.

calibration stick A (shif-click to mark end 1) -
1 I 1D

3. Type in the provided box to change the length of the Calibration Stick. Enter the
length of the physical object. In this example, the measuring tape was set to 1
meter, so you would set the Calibration stick to 1 meter.

-1.00[] m
"

P ettt e T R —
e e e T B ot et o S e T = ———

Right-click to format [l

S
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4.

If you want to change the color of the Calibration Stick (if it is hard to see),
go to Calibration Stick A > Color.

sH|s @ m e b SN %A A4 A
7| A calibration stick A | step 0: length[1.000 m | angle from x-axis[-05° |

¥ Visible
[J Locked

¥ Fixed

5. Select a color from the palette and click OK.

@J Choose Track Color
[ Swatches | HSV | HSL | RGB | CMYK |

T )
JIIIIIIIIJJJJJJJJ# Recent:

Preview

| oKk || Cancel H Reset
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Coordinate Axes

In addition to the Calibration Stick, you need to add the Coordinate Axes to your video
so Tracker can determine the x and y positions relative to the origin.

1. Click the Coordinate Axes button to add the axes to the video.

S & Bl | B w-|l | *¥create == & | Q108% | . 0l

@ Tracker — O X
File Edit Video Track Coordinate System View Help

SH| S E| 8w || koo = 8| Qan |7 0b |\ % A A4 4|4 K /-0 ac
¥ _ calibration stick A step 0: length[1.000 m | angle from x-axis[-0.5° | memory in use: 7MB of 247TMB

94
¥ ke -

Plotview of track data will appear here

Table view of track data will appear here

:;:u(mmu%EIn L 201 E

[ RRREROR

IMG_22351rk |
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2. Move the axes to line up with the horizontal and vertical lines in your video. If the

reference lines in your video are rotated a little bit, grab the positive x-axis and
rotate the axes to match the video.

= 3| & B | B - || Xcreate == @ | Quasn | 7 o | ™ o A A | Z A |
¥ —}axes [ ]Grid v origin pixel position angle from horizontal .0 5 |

3. If you want to change the color of the Axes (if they are hard to see),
go to Axes > Color.

S H & B 8w |
| —}— axes |[ ] Grid ¥ origin pixel po!

Footprints »
¥ Visible
IJ Locked
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4. Select a color from the palette and click OK.

|£| Choose Track Color *
[ Swatches | HSV | HSL | RGB | CMYK |

OO O
[ IJJ_I_I_I_IJJJ Recent:

Preview

| ok || Cancel H Reset |

Create a Point Mass

For every object that you track, you will need to create a Point Mass.

1. Click Create > Point Mass.

I &2 Bl B ‘- |l || *create |-= 8  (Q28% . 0l

¥ —}-axes []Grid ¥ origin pixel pos| Point Mass 430E3 | angle from horizo
Center Of Mass

Vector
Vector Sum S

Line Profile
RGB Region

Kinematic Model
Dynamic Model »
External Model »

Measuring Tools »

Calibration Tools »
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2. Name the Point Mass. This is especially useful for experiments when you are
tracking multiple objects.

3. Click the current name of the Point Mass. In this case, mass A. Then click Name.

S H| & B8 w- || ¥create =0 8 | Qasw | o 0l

Footprints

¥ Visible

[0 Locked
Autotracker...
Define...

¥ Autostep

IZ Mark by Default
Velocities »
Accelerations 4

Delete Selected Step

Clear Steps
Delete

4. Type the new name and hit Enter on the keyboard.

@ set Name X || @ et Name *

Name:|mass A || |Name: Ball |

Don’t bother entering the object’'s mass for the Point Mass unless you plan to do the

analysis in Tracker. Analyzing data in Tracker is not very easy, so it is probably best to

analyze the data elsewhere (Excel, Google Sheets, etc.).

Table of Contents

12



Track the Object

After creating your Point Mass, you will mark the object’s position for each frame of the
video that you need.

1.

Slide through the video to find the first frame you want to track. Use the slider on
the bottom of the video to move quickly through the video and use the Step
buttons to move by 1 frame at a time. If the camera moved from where it was
when you aligned the axes, you may need to adjust their position/angle.

1
i)
R

. L I | I
-

To add a tracking point, hold down Shift on the keyboard and click on the object
to add a mark at that position. The video then automatically advances to the next
frame so you can add the next point.

Use the scroll wheel to zoom in and see the object better.

@ Tracker — [m] X
File Edit Video Track Coordinate System View Help
2| & Bl B v || kcreae = 8 | Qean | o 0|y o A A A A 4 A #- 5 o ¢
v © Ball m memory in use: 71MB of 247MB
Track Control x :; o Plut‘ < Bﬂl|v| “
& Ball }f Ball it, %)
§ -0.65
-0.70
H -0.78
= o -0.&n 4
. ! H
‘4 | gones
e A E
A% 'L.-J""'g E i =m0 '/
o =4 N =]
' =l =il e e
o s : -1.00
y i e /

015 020 025 030 0.35 040
3

I — | - g,.| - | —

tis) () Y (T

0.133 -1.087] 0.557]
0.167) -1.039 0.641
0.200 -0.958 0.711
0.233 -0.940) 0.770
0.267) ~0.890) 0.821
0.300 0841 0.850
0333 0791 0889
0.367) ~0.748 0.907}
0.400 -0.698 0.916
0.433 0.647] 0.917]

‘ Ii Dk

i I} o

©oo14 100%E|n » a1 n T

. “ - f

IMG_2235.1rk |
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3. Always choose the same point to track on the object for each frame of the video.
Choose a mark that is easy to see, such as the middle, edge, or corner of the
object.

4. When you finish tracking the object, some of the tracking marks will be hidden.

If you want to change how many you can see at a time, click the button for Trail
Length and change it accordingly.

= |5 Bl| 8B w- || ¥create == 8 | Q as% ||~
¥ < Bal m[1.000kg]

Track Control

< Ball

Table of Contents

X

o | ™\ & A A | 4 Z |

O No trails
T © Short trails
; < Long trails
BRn ® All steps

Ball selected (set mass on toolbar, shift-click to re-mark highlighted position)

-
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Graph

Although you probably won’t do any analysis in Tracker, it can sometimes be useful to
see the graph of the data while you are tracking the objects.

If you want to change which variable the graph displays, click the axis you want to
change and select the new variable.

- Plot| & Ball|w all k. Plot| © Ball|w a
Ball (t, x) Ball (t, y)
'Uno T T T T T T 5= T
0.8
-0.2F
04} o
—— E
® x position x-component = 04
O y: position y-component
© r: position magnitude ] 02k
© 8r: position angle
© wx: velocity x--component J oL
© vy: velocity y-component " 1 " ! 4 1 4 L "
© v velocity magnitude 0.7 08 02 03 04 05 06 07 08
© 8v: velocity angle te)
Y av ancalaratinn v ArarmanAanant
Data Table

Before exporting the data from Tracker, you will need to select the data in the table.

1. If you tracked more than one object, select the object in the drop-down menu
above the table.

[ Table | © Ball |w a
ts) | Ball[selectatrack}y

0l Ball2_ J5o5 0.916|4
0.433 20.647 0.917
0.467 -0.600 0.905
0.500 -0.550 0.883
0.533 -0.501 0.850
0.567 -0.450 0.809}—
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2. Click the Table button to bring up the column selection window.

[[] Table| © Ball|w ~

t(s) x(m) | y(m) |v(mis)| v (mis)
0.133] -1.087 0.557 -~
0.167] -1.039 0.641] 1.492 2.304
0.200] -0.988 0.711] 1.495 1.939
0.233] -0.940 0.770] 1471 1.653
0.267] -0.890 0.821] 1.473 1.340
0.300] -0.841 0.860] 1.476 1.028
0.333] -0.791 0.889] 1.426 0.715
0.367| -0.746 0.907] 1.403 0.402
0.400] -0.698 0.916] 1.483 0.142
0.433] -0.647 0.917) 1460 -0.170}—
0.467| -0.600 0.905] 1.462| -0.509
0.500] -0.550 0.883] 1.491] -0.821
0.533] -0.501 0.850] 1.493] -1.108
0.567] -0.450 0.809] 1.522| -1.420
0.600] -0.399 0.756] 1.473] -1.785|w

Il

3. Select the columns you need for the experiment and click Close.

Visible Table Columns >

<> Ball

] x ] y Clr []er
(1] e o] vy v ] v
[] ax L] ay []a []8a
L] px L] py Llp L] 6p
L[]8 L] w [la LK

[ ] step [ Jframe [ ]pixelx [ ] pixely
LIL

Define... Text Columns Close
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Export Data

After selecting the variables you want in the table, export the data either via Copy &
Paste or in a CSV file.

Export Data via Copy & Paste

1. Double Click on the data in the table to select it all.
2. Right Click on the data and go to Copy Selected Cells > Full Precision.

[[ Table | ¢ Ball|w a
t(s) ¥ {m) ¥ (m) | v (mis)| v (mis)

0‘1"!"! 4 /0D DEeE"T -~
0.1 GoTo Step 4 1.492] 2304
gz Copy Selected Cells »| Full Precision
0j2 Numbers »| As Formatted i
gda Text Columns »| Set Delimiter » }
0.3 Copy Image 1.403 0.402
04 spapshot... 1.483] 0.142
0. 1.460] -0.170}—
0.4 Define... 1.462| -0509
0.5 Analyze.. 1.491] -0.821
0.5— 1.493] -1.108
0.5 Print... 1522 -1.420
08 Help.. 1473] 1785+

3. Paste the data into a spreadsheet (Excel, Google Sheets, etc.).
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Export Data via CSV File

1. Go to File > Export > Data File

@ Tracker

| File| Edit video Track Coordinate System View Help

New Tab

Ctrl-N

= Open File...
Open Recent

Ctrl-O
»

| X Create = @ |

&> Open Library Browser...

Close All Tabs

Close Tab "IMG_2235.trk"

Save Tab As...

(2] save Project As...
Save Tabset As...

[ save Tab "IMG_2235.trk” cil-s

Import

Video Clip...

Tracker File...

Print...

Ctrl-P

2. Set the export parameters as shown below and click Save As.

Thumbnail Image...

Export Data by
-Data Table ~Cells
Ball (2) - All Cells -
~Number Format —  Delimiter
Full Precision |+ Comma -
Save As... Close
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3. Choose a file location, name the file with the extension “.csv”, and click Save.

(£ Save Data As hod
Save In: |[] Documents E
File Name: |Elall_data.|:su |
Files of Type: |AII Files |-.-|

Save Cancel

4. Use your spreadsheet (Excel, Google Sheets, etc.) to import the CSV file. Follow

the video demonstration for Google Sheets or look up instructions online if you

don’t know how to do it.
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Export Thumbnail Image

If you want to export an image from Tracker showing the video with tracking marks, you

can take a screenshot or export a thumbnail image.

1. Go to File > Export > Thumbnail Image

@ Tracker
- Edit Video Track Coordinate System View Help
New Tab Ctrl-N | ¥ Create == @ ‘
= Open File... cir-0
Open Recent 4

& Open Library Browser...
Close Tab "IMG_2235.trk"
Close All Tabs

[ save Tab "IMG_2235.trk" culs
Save Tab As...

(2] save Project As...
Save Tabset As...

Import
Video Clip...
Tracker File...

2. In the pop-up window, you can choose the type of thumbnail to export, the image

resolution, and the file type.

Export Thumbnail Image et
Image

Entire Frame -
Size Format

320x240 - PNG Image |+

Save As.. || Close
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3. For the type of thumbnail, you can choose between Entire Frame, Main View,
and Video Only.

Export Thumbnail Image X

Image

Entire Frame -

Entire Frame
Main View
Video Only

Save As... Close

4. You can choose from a variety of image resolutions. It would be good to select

something large so you get a high quality image.

Export Thumbnail Image x

Image

Entire Frame -

Size Format
1024x 768 - PNG Image |«

1024x768
512x384 Close
—320x240 —
240x180
160x120
120x90
B0x60

5. For the file type, you can choose between PNG and JPEG. Either one is fine.
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